Welcome to Wistia's home for real-time information and updates on our applications. Here you'll find live and historical data on system performance and metrics. If there are any service interruptions, a note will be posted here.
Analytics Database Maintenance
Completed
Scheduled for March 10, 2025 at 12:00 PM – 1:00 PM
Affects
Stats
Under maintenance from 12:00 PM to 1:00 PM
Updates
Completed
March 10, 2025 at 1:00 PM
Completed
March 10, 2025 at 1:00 PM
Maintenance has completed successfully
In progress
March 10, 2025 at 12:00 PM
In progress
March 10, 2025 at 12:00 PM
Maintenance is now in progress
Planned
March 10, 2025 at 12:00 PM
Planned
March 10, 2025 at 12:00 PM
We are planning for a scheduled maintenance to our analytics database. Stats may be delayed during this time.